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1. Overview

The Atmel Microcontroller ISP Software is the primary means for performing in-system
programming (ISP) for the Atmel devices.  It provides an intuitive interface for in-system
programming that can be run from your personal computer.  The Atmel ISP Software has
a comprehensive set of features that allows you to view, program, and erase data from an
Atmel ISP device.

The Atmel Microcontroller ISP Software also allows you to load hex files containing the
code you want to add to the device.  Using the software, you can manipulate this code,
verify it against the existing code on the device, and program the code onto the device.

Additionally, using the software, you can read any existing code from the device and
make minor changes to the code.  You can then update the device with your changes or
save them to a hex file for use with other devices.

The software also allows you to protect third parties from accidentally reprogramming
the device and even allows you to lock the device so that the code cannot be read from it.

Atmel’s Microcontroller ISP Software contains a variety of tools customized for Atmel
ISP devices.

For more information about ISP, refer to the Atmel Data Sheet that came with your
Atmel Microcontroller device.
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2. System Requirements

Atmel’s Microcontroller In-System Programming Software will run on Windows 9x,
Windows NT 4.0 with Service Pack 3 or later, or Windows 2000 operating systems.  The
software will not run on Windows NT 3.51 or any prior version.

Minimum Hardware Requirements:

• Intel Pentium-class processor; Pentium 166 or higher processor recommended
• 32 MB of RAM (64 recommended)
• CD-ROM drive
• VGA or higher-resolution monitor; Super VGA recommended
• Microsoft Mouse or compatible pointing device
• Atmel ISP Cable
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3. Getting Started

Whether or not you are familiar with using in-system programming software, you will
find Atmel’s software easy to use.  The interface is intuitive and easy to learn.  This
section will help you install the software correctly and give you a quick walkthrough on
how to program an Atmel microcontroller chip.

3.1. Installation

To install Atmel’s Microcontroller ISP software insert the CD or 3 ¼” floppy (Disk1).  If
you have auto play enabled on your computer and you are installing from a CD the
installation will start up automatically.  Otherwise, use Windows Explorer to browse the
CD or floppy and click on Setup.exe.  The install wizard will then guide you through
the installation.

3.2. Selecting a Device

Once the software has been successfully installed you are ready to run the program.  You
can run the program by selecting
Programs����Atmel���� Microcontroller ISP Software from the start menu.

After starting the program you will see the window depicted in Figure 1.
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Figure 1 - Atmel Microcontroller ISP Software

You will notice that most of the toolbar buttons and menu options are disabled.  This is
because a device has not been selected.  To select a device, do the following:

1. Make sure the board is connected to the LPT port of your computer with the Atmel
ISP cable and that the board is turned on.

2. Select the LPT port that the board is connected to by selecting Select Port from the
Options menu (You could also press the select port  toolbar button).

3. You can then select a device by choosing Select Device from the Options menu or by
clicking  on the toolbar. You should see a dialog box similar to the one in Figure 2.

Note: You can select a device before powering on the board but you must
manually select the Initialize Target menu option from the Options menu
before performing any device instructions.
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Figure 2 - Device Select Dialog

4. Select the device that you are trying to program from the tree control by clicking on
the desired device.

5. Next select whether you want to read and write from the device in page mode
(read/write a page at a time) or in byte mode (read/write byte by byte).

6. Enter the external clock frequency (MHz) provided to the device in the text box.

7. Select OK.

Once you finished selecting a device you will see one or two windows appear depending
on whether or not the device has internal data memory.  The window(s) will look like
Figure 3.  Each window signifies a buffer.  There are two types of buffers, a code buffer
and a data buffer.  The code buffer corresponds with the in-system programmable flash
memory of the chip and the data buffer corresponds with the chip’s internal data memory.

Note: The page mode selection will be disabled if the device does not support
page mode.



7

Figure 3 - Buffer Window

3.3. Basic Device Operations

This section discusses the basic operations that are routinely performed when
programming a device.  This section does not explain all the full functionality of the
program.  For information on all the functions of the program see section 4 -
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Menus and Toolbars.

3.3.1. Checking the state of the device

One of the first things you should do before attempting to program a device is to
check its state.  To check a device’s state select Blank Check from the
Instructions menu.  After selecting Blank Check, the software will report one of
the following four states:

• Not able to Communicate with Device

The program will report that it was not able to communicate with the device if
the device is not powered on.

• Erased and Programmable

This means that the chip is completely blank and it is not locked.

• Programmed and Programmable

This means that the chip has been programmed and it is not locked.

• Locked

The device is locked (For more information on a device being locked see
section 3.3.4 - Device security).  If the device is locked and you wish to
program it you may choose Erase Chip from the Options menu.

3.3.2. Loading a buffer from a file

After determining if the device can be programmed or not, it is time to load the
program that you wish to encode onto the chip into the software.  The Atmel
Microcontroller ISP Programming software can load in programs that are in the
Intel Hex file format.
To load in a program from disk:

1. Select Load Buffer from the File menu or click  on the toolbar.  You will see
a dialog similar to Figure 4.

Warning: By erasing the chip you will be destroying any prior program on the
device as well as unlocking it.  If you do not wish to lose the program on the
chip then it is not recommended to do a chip erase.
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Figure 4 - Load Buffer Dialog

2. Select the HEX file that contains the program you wish to encode onto the chip
and click Open.

3. The buffers will then be updated with the contents of the hex file.

3.3.3. Programming the Device

Once the program has been loaded into the buffer(s) the most straightforward way
to program the device is to select Auto Program from the Instructions menu (You
can also press  on the toolbar).  Auto program performs all of the most common
tasks done when programming a device.

Auto programming performs the following commands:

• Erases the device
• Writes out buffer(s) to the device
• Verifies programmed device with buffer contents
• Prompts user for lockbit settings (if supported by device)
• Prompts user for fusebit settings (if supported by device)

After selecting Auto Program you should see a progress dialog similar to the one
shown in Figure 5.
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Figure 5 - Progress Dialog

If at any time during auto program one of the steps fails, the auto program feature
will report the error and abort (For reasons why the programming process might fail
see Section 5 - Troubleshooting).

3.3.4. Device security

During the auto program process you will be prompted for both lockbit settings and
fusebit settings if the device supports them.  Lockbits and fusebits are a way for the
developer (you) to add security to the code you just encoded onto the device.  Most
devices support settings that allow you to disable writing to the device, disable both
reading from and writing to the device, and even disable writing, reading, or
externally executing the device (See device’s data sheet on specific information on
its security features).

3.3.5. Setting the Device to a Run State

After programming the chip and setting all the necessary security features you can
remove the device out of ISP mode by selecting Run Target from the Instructions
menu.  This will start the device executing the code you just programmed onto the
chip.

Note: The only way to clear lockbit/fusebit settings is to perform a chip erase.
It is also not possible to set the lockbits/fusebits at a lower security level then
they are currently set at.  You may only increase the security level.

Note: Once you select Run Target you will not be able to send any
instructions to the device (most menu items will be disabled).  In order to
interact with the device again you must select Initialize Target from the
Options menu.



11

4. Menus and Toolbars

This section describes the Atmel Microcontroller ISP software’s menus and toolbars.  It gives
descriptions of the various commands that can be executed from the menus and toolbars.

4.1. File Menu

The File Menu allows the user to transfer information between hex files and the Atmel
Microcontroller ISP Buffer.  Executing these commands in no way modifies the contents
of the device.

Load Buffer
The Load Buffer command prompts the user to select a hex file from which to load
information.  This command takes the information from the hex file selected and places it
into the correct buffer(s).  The resulting buffer(s) are then displayed on the screen.

This command can also be activated by clicking  on the toolbar.

Save Buffer
The Save Buffer command prompts the user to select a file name to write the program’s
buffers’ information out to.  This command takes the information from the program’s
buffers, formats it into the correct hex format, and places it into a file.

This command can also be activated by clicking  on the toolbar.

Exit
The Exit command shuts down the Atmel Microcontroller ISP Software.

4.2. View Menu

The View Menu allows the user to show or hide different parts of the graphical interface.

Toolbar
The Toolbar command either shows or hides the toolbar portion of the graphical
interface.  If the Toolbar command has a check beside it, the toolbar is currently being
shown and will disappear if the Toolbar command is selected.  If it is unchecked, clicking
it will force the toolbar to appear.

Status Bar
The Status Bar command either shows or hides the status bar portion of the graphical
interface.  If the Status Bar command has a check beside it, the status bar is currently
being shown and will disappear if the Status Bar command is selected.  If it is unchecked,
clicking it will force the status bar to appear.
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4.3. Buffer Menu

The Buffer Menu allows the user to perform various operations on the Atmel
Microcontroller ISP buffers displayed on the screen.  Through this menu, the user can
edit and verify the buffer.

Blank Check (Buffer)
The Blank Check (Buffer) command checks through any buffers currently in memory and
tests to see if the buffers are completely empty.  This command then returns the results
for each buffer to the user.

Erase Buffer
The Erase Buffer command completely empties any buffer currently in memory.  This
command sets each spot in every buffer to the current device’s blank value.

Fill Buffer
The Fill Buffer command allows the user to fill any portion of a buffer with a pattern of
bytes.  When the user clicks on Fill Buffer, a dialog similar to the one in Figure 6 is
shown.

Figure 6 - Fill Buffer Dialog

The Fill Buffer dialog will fill in the buffer that is currently selected in the main window.
The user fills in the starting address, ending address, and the value with which to fill the
buffer.  If the user enters an invalid address, the dialog will reset it to a valid address.  If
the user enters a fill value that does not have an even amount of hex values, it will append
a zero to the beginning of the hex string.  Once the user clicks the OK button, the buffer
will be filled as the user specified.

Check Sum
The Check Sum command sums up all of the bytes in any buffer currently in the
program’s memory.  The results for each buffer as well as the overall total are then
displayed on the screen.

Note: The Erase Buffer command does not erase the actual chip’s buffer.
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4.4. Instructions Menu

The Instructions Menu allows the user to send commands to the device.  Through the
menu, the user can conduct reads, writes, and other device communications.  When
necessary, the display buffers are updated automatically.

Blank Check (Instructions)
The Blank Check (Instructions) command checks the status of the device currently
connected.  After conducting the test, one of the following results are displayed on the
screen:

- Unable to communicate with the device.
This status means that the software is unable to send commands to the
device.  This could be caused by a defective device or by not having the
power turned on.

- This device is ERASED and PROGRAMMABLE.
This status means that the device is blank and is ready to be programmed.

- This device is PROGRAMMED and PROGRAMMABLE.
This status means that the device already has some data programmed into
it.  However, the device is not locked and is ready to receive more
information.

- This device is LOCKED.
This status means that the device is in a locked state.  This mode prevents
anyone from writing to the device and, depending upon the chosen lock
state, could prevent reading from the device as well.

Erase Chip
The Erase Chip command erases the device’s buffers.  After performing an erase chip,
the device’s memory, both FLASH and data, will be blank and the device will be in a
programmable state.

Read Chip
The Read Chip command reads in the device’s memory.  The results from the read are
loaded into the Atmel ISP software’s buffer and displayed on the screen.
This command can also be activated by clicking  on the toolbar.

Write Chip
The Write Chip command writes all memory locations in the Atmel ISP Software’s
buffer out to the device’s memory.  A progress dialog appears to let the user know that
the write is taking place and to notify the user when the operation finishes.

Note: If there is no device connected at the end of the serial cable, a locked state
is returned to the user.
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This command can also be activated by clicking  on the toolbar.

Lockbit Settings
The Lockbit Settings command allows the user to set the lockbit protection mode for the
current device.  A dialog box, similar to Figure 7, showing the protection modes
supported by the current device is displayed to the user.  After selecting a protection
mode, the software sets the device to the specified mode.

Figure 7 - Lockbit Manager Dialog

Fusebit Settings
The Fusebit Settings command allows the user to set the fusebit protection mode for the
current device.  A dialog box, similar to Figure 7, showing the protection modes
supported by the current device is displayed the user.  After selecting a protection mode,
the software sets the device to the specified mode.

Check Signature
The Check Signature command reads the signature bytes from the device.  These bytes
are then displayed on the screen.

Verify Chip with Buffer
The Verify Chip command compares the Atmel ISP Software buffer with the device’s
internal memory.  If the buffers are found to be exact replicas of the device’s memory, a
success result is returned.  If there are any differences, a failure result is returned along
with the total number of mismatched bytes.
This command can also be activated by clicking  on the toolbar.

Auto Program
The Auto Program command performs a series of operations on the device.  This
command initially erases the chip.  Following the chip erase, the Atmel ISP Software
buffer is written out to the device.  After writing out the buffer, the chip is verified to
ensure the write worked correctly.  Finally, the user is prompted to choose a lockbit mode

Note: The only way to clear lockbit/fusebit settings is to perform a chip erase.  It is
also not possible to set the lockbits/fusebits at a lower security level then they are
currently set at.  You may only increase the security level.
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setting and/or a fusebit mode setting if the device supports these features.  All results
during and after the Auto Program command are displayed in a progress dialog.
This command can also be activated by clicking  on the toolbar.

Run Target
The Run Target command removes the device from programming mode and sets it into a
run state.  When the device is in this state, programming commands can not be sent to the
device.  Most of the commands in the Atmel ISP Software are disabled during this state.
To return to a programming state, the Initialize Target command must be executed.

4.5. Options Menu

The Options Menu allows the user to define various settings for which the Atmel ISP
Software will use to communicate with the device.

Select Port
The Select Port command sets the parallel port to which the device is connected.  A
dialog box appears that allows the user to choose between LPT1 and LPT2.
This command can also be activated by clicking  on the toolbar.

Select Device
The Select Device command sets the device type so the Atmel ISP Software knows what
type of device with which to communicate.  A dialog box, similar to Figure 8, allows the
user to see all devices that are currently supported.  The user clicks on the desired device
to choose that device.  Then, the user must choose either page mode or byte mode for
read and write commands to the chip.  Finally, the user must enter the XTAL frequency
on their device’s board.

Figure 8 - Device Select Dialog
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This command can also be activated by clicking  on the toolbar.

Initialize Target
The Initialize Target command sets the device to programming mode.  This is needed
when swapping devices after already selecting the device in the Atmel ISP Software.
Additionally, it is needed when setting the device out of run mode.
This command can also be activated by clicking  on the toolbar.

Customize Display
The Customize Display command configures the colors for the buffer windows.  A dialog
is displayed that shows the current color configuration and buttons for updating the
individual colors (Figure 9).

Figure 9: Color Configuration Dialog

The user configures the individual colors by clicking on the Foreground, Background,
or the Mismatch buttons.  Once a button has been clicked a color selection dialog
appears (Figure 10).  The user can then click on the desired color and then click Ok to
update the color.
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Figure 10: Color Selection Dialog

4.6. Window Menu

The Window Menu allows the user to change the layout of the buffer windows in the
display.

Tile Horizontal
The Tile Horizontal command arranges the buffer windows in non-overlapping tiles in a
column one above one another.

Tile Vertically
The Tile Vertically command arranges the buffer windows in non-overlapping tiles in a
row one right next to one another.

4.7. Help Menu

About
The About command displays information about the current running version of the Atmel
ISP Software.

4.8. Toolbar

The toolbar is displayed across the top of the Atmel ISP Software window, below the
menu bar.  The toolbar provides quick mouse access to many commands in the Atmel ISP
Software.  The toolbar supports the following commands:
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Loads a hex file into the buffer.  See the Load Buffer command for more
information.

Saves the buffer into a hex file.  See the Save Buffer command for more
information.

Selects a port to look for the device on.  See the Select Port command for
more information.

Selects a type of device to program onto.  See the Select Device command
for more information.

Initializes the target device.  See the Initialize Target command for more
information.

Writes the buffer out to the device.  See the Write Chip command for more
information.

Reads the device’s information and adds it to the buffer.  See the Read Chip
command for more information.

Verifies that the device contains the same information shown in the display
buffer.  See the Verify chip command for more information.

Programs the chip through a series of steps.  See the Program Chip
command for more information.

Displays the code buffer (if hidden) and sets it as the active window.

Displays the data buffer (if hidden) and sets it as the active window.  If
there is no data buffer, this button does not change the current active
window.
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5. Troubleshooting

This section discusses some of the common problems you might encounter when using the
software and what to do when you encounter them.

The program reports that the device is locked even after a Chip Erase command has been
executed.

The software is most likely having trouble communicating with the device.  Check the
cable connection and make sure the device is on.  Then run the Initialize Target
command from the Options menu.

The program reports write failures when attempting to write the buffer(s) to the chip.

This usually occurs when the XTAL frequency is not set to the correct value in the
software.  To set the XTAL chose Select Device from the Options menu and input the
correct XTAL frequency that is being used by the device.  Then run the Initialize Target
command from the Options menu.

The software reports “…Atmel ISP Cable is not connected…” but the cable and device
appear to be connected properly.

Make sure the correct port is selected in the software.  This is done by selecting Select
Port from the Options menu.


